# Studio page editing and 500 Internal Server Error

**URL:** https://community.pickaxe.co/t/studio-page-editing-and-500-internal-server-error/4473
**Category:** Bugs / Site Issues
**Created:** [March 5, 2025, 8:11pm UTC](https://community.pickaxe.co/t/studio-page-editing-and-500-internal-server-error/4473 "2025-03-05T20:11:53Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![equipeid](https://avatars.discourse-cdn.com/v4/letter/e/d07c76/32.png) [@equipeid](https://community.pickaxe.co/u/equipeid)
#### Post date: [March 5, 2025, 8:11pm UTC](https://community.pickaxe.co/t/studio-page-editing-and-500-internal-server-error/4473/1 "2025-03-05T20:11:53Z")

</div>

Hi,

I have migrated to the new pickaxe and it’s been really tricky.

I cannot find where to edit the studio from the user’s perspective to organize the pickaxes, include and remove pickaxes in specific tabs, create or edit content pages etc

 ![Imagem1](https://canada1.discourse-cdn.com/flex004/uploads/pickaxeproject/original/2X/9/9dca9d48b904dcba99ace4ca080f9e7bde620cf9.png)

I have wondered if it could be the “website” section below the new studio, but when I click to edit show “500 - Internal Server Error”.

Thanks,

Felipe

---

<div class="post-metadata">

### Author: ![admin\_mike](https://yyz2.discourse-cdn.com/flex004/user_avatar/community.pickaxe.co/admin_mike/32/283_2.png) [@admin\_mike](https://community.pickaxe.co/u/admin_mike)
#### Post date: [March 6, 2025, 12:42am UTC](https://community.pickaxe.co/t/studio-page-editing-and-500-internal-server-error/4473/2 "2025-03-06T00:42:54Z")

</div>

Do you have a custom domain on this particular studio? Is this a studio that got migrated from the old system? Or did you build it in the new system?

I will ping @nathaniel to look into this issue as well.

---

<div class="post-metadata">

### Author: ![equipeid](https://avatars.discourse-cdn.com/v4/letter/e/d07c76/32.png) [@equipeid](https://community.pickaxe.co/u/equipeid)
#### Post date: [March 6, 2025, 3:42pm UTC](https://community.pickaxe.co/t/studio-page-editing-and-500-internal-server-error/4473/3 "2025-03-06T15:42:01Z")

</div>

Hi @admin_mike and @nathaniel

Here are the responses:

Do you have a custom domain on this particular studio?  
Yes, they are all custom domains

Is this a studio that got migrated from the old system? Or did you build it in the new system?  
Yes, all of them are from the old system

Mike, I have tried now and the 500 error is over.

We have a new issue: I am not able to create new content pages or add new pickaxes there. I am not able to edit content pages as well.

Would you help me please?

---

<div class="post-metadata">

### Author: ![admin\_mike](https://yyz2.discourse-cdn.com/flex004/user_avatar/community.pickaxe.co/admin_mike/32/283_2.png) [@admin\_mike](https://community.pickaxe.co/u/admin_mike)
#### Post date: [March 6, 2025, 4:48pm UTC](https://community.pickaxe.co/t/studio-page-editing-and-500-internal-server-error/4473/4 "2025-03-06T16:48:23Z")

</div>

What happens when you add a new content page or try to edit one? Do you get an error message?

---

<div class="post-metadata">

### Author: ![equipeid](https://avatars.discourse-cdn.com/v4/letter/e/d07c76/32.png) [@equipeid](https://community.pickaxe.co/u/equipeid)
#### Post date: [March 6, 2025, 5:56pm UTC](https://community.pickaxe.co/t/studio-page-editing-and-500-internal-server-error/4473/5 "2025-03-06T17:56:12Z")

</div>

Hi Mike,

Now I can find the button to add new pickaxes or content pages or folders.

But When I try to edit the already content pages it doesn’t show the content to be edited, but this information:

 ![image](https://canada1.discourse-cdn.com/flex004/uploads/pickaxeproject/original/2X/d/d3ef5f138d272d49dfd0956ae00f493c020e1652.png)

Thanks,

Felipe

---

<div class="post-metadata">

### Author: ![stephenasuncion](https://yyz2.discourse-cdn.com/flex004/user_avatar/community.pickaxe.co/stephenasuncion/32/3111_2.png) [@stephenasuncion](https://community.pickaxe.co/u/stephenasuncion)
#### Post date: [March 6, 2025, 6:00pm UTC](https://community.pickaxe.co/t/studio-page-editing-and-500-internal-server-error/4473/6 "2025-03-06T18:00:43Z")

</div>

Hi @equipeid,

Toggle “Make visible to guests” for now, then you can see the page. Alternatively, login with your Pickaxe account to use the studio as “owner”.

We’ll probably automatically login people as the owner in the future.

---

<div class="post-metadata">

### Author: ![admin\_mike](https://yyz2.discourse-cdn.com/flex004/user_avatar/community.pickaxe.co/admin_mike/32/283_2.png) [@admin\_mike](https://community.pickaxe.co/u/admin_mike)
#### Post date: [March 7, 2025, 7:51pm UTC](https://community.pickaxe.co/t/studio-page-editing-and-500-internal-server-error/4473/7 "2025-03-07T19:51:14Z")

</div>


